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Dreamweaver MX 
Getting Started and Page Basics 

 
Outline of section: 

i. The “process” of making a web page 
ii. General introduction to web authoring packages 

iii.  Setting up a site in Dreamweaver 
iv. Tour of Dreamweaver opening screen 
v. Set general page properties 

vi. Save your page and preview it in a web browser 
 
i.  The “process” of making a web page 
 
There are a few simple tips to emphasize before we get started in Dreamweaver. 
 
First, creating a web page should be a very iterative process.  Take a look at the 
schematic below: 
 
Plan it  Edit it  Edit it  Edit it 
Create it �  Test it �  Test it �  Test it  �   ETC.! 
Test it  Upload it Upload it Upload it  
Upload it 
 
A good web page is probably never completed – it’s always a “work in progress” or 
“under construction.”  Today you’ll plan your page and then you’ll learn how to create 
your web page.  Once you create it, you’ll test it, preferably in multiple browsers.  This 
ensures that your page looks readable whether visitors to it are using Netscape or Internet 
Explorer on a Mac or on a PC.  Once it’s ready for prime time, you’ll publish it to a web 
server (this process is called “uploading,” or “ftp-ing”).   
 
Importantly, once you publish your page, you (and your students and colleagues) will 
probably discover ways to improve and enhance and correct your web page.  So you’ll 
edit your page, at which point you’ll need to test it and upload the revised page onto the 
web server.  You’ll edit, test, and upload your page many, many times in the course of its 
public life on the web. 
 
Second, create a single folder on your computer for the purpose of storing your web 
pages and associated files before you start work on your pages.  Dreamweaver 
REQUIRES this!  Keep everything associated with your web site within this folder.  
Relevant elements might include web pages, images, Word documents, clip art, etc.  We 
recommend that you create a working web folder on your H: drive, but you can use your 
C: drive if you prefer.  For this class, we’ll create a folder with you course name and 
place it on your H: drive. 
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This is an important tip for two reasons.  First, it preserves the relationship between your 
pages and links and pictures and such.  Second, it makes it easier to make a backup of 
your work onto a different drive, and it is also easier to transfer (“upload” or “ftp”) your 
work onto a web server when you are ready. 
 
ii.  General introduction to web authoring packages 
 
Web pages are coded in a scripting language called HyperText Markup Language 
(HTML).  Web browsers are nothing more than programs that interpret the HTML code 
and display the pages appropriately. 
 
Compare the technical coding of a page to how the page looks in your browser.  To do 
this, pull up the following web page in your favorite browser: 
http://www.coloradocollege.edu/dept/AN/index.htm 
 
First, notice how the page looks when you view it in Internet Explorer or Netscape.  Text 
is formatted in different ways, and there are colors and pictures and links and such.   
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Now look at the “Source” under the View menu in your browser.  This shows you the 
HTML code required to make the page look the way it does above. 
 

 
 
 
This source code is responsible for the “pretty” Anthropology  web page looking the way 
it does in the screen snapshot above.  Notice that there is only the text from the page, 
along with references to the links and images embedded within the page.  The HTML 
commands are called “tags,” and they appear within brackets (such as <html>) 
throughout the window above. 
 
Understanding HTML is useful, especially for advanced web work, but it is not necessary 
for beginners and intermediate web authors.  For more basic web page creation, we want 
to use a software package that makes the creation of web pages easier, and that does the 
HTML scripting for us. 
 
Such a tool is Macromedia Dreamweaver. Dreamweaver is a full-featured web design 
tool used effectively by beginning web authors all the way up to professional web 
designers.   Dreamweaver essentially offers a “WYSIWYG” interface, which stands for 
“What You See Is What You Get.”  In the program’s Layout view, you can use 
Dreamweaver to visually design your web page (just as you are used to working within a 
word processor).  Advanced designers appreciate Dreamweaver’s robust editing features 
when they want to dig deeply into the HTML code.  As you’ll see as we work with 
Dreamweaver for beginners, you can generally forget about HTML coding and focus 
more on your content and how to format it appropriately for the web environment. 



Dreamweaver MX: Created by M. Gerein; Modified by P.Quinn ~ 20 

 
A final point about Dreamweaver as a web authoring tool: Don’t worry too much about 
the specifics of one web program versus a different one.  The concepts that you learn 
using one program will translate nicely into (or from) a different program.  However, 
there is one important difference between Dreamweaver and some other editing 
packages, and we’ll be discussing it in the next section. 
 
iii.  Setting up a local site in Dreamweaver 
 
There is one important difference between Dreamweaver and some other web editing 
packages, and that is that Dreamweaver requires you to set up a “local site” to hold your 
web files.  The reason why Dreamweaver is structured this way is that it is a site 
management tool as well as a web authoring tool, and defining a site makes it possible for 
Dreamweaver to give you a site map as well as check for broken links.  Although in this 
class we won’t be learning about the site management features of Dreamweaver in any 
depth, we do need to explain how to set up a site.  It may not make much sense, but you 
should only have to do it once on your computer. 
 

1. To create a new local site, begin by creating a folder to hold all your files.  You 
can put this on your network drive, or on the hard drive of your computer. 

2. Once you’ve created a folder to hold your files, choose “Manage site…” from the 
“Site” menu and then “New”.  A dialog box like the one below will appear: 

 
 
 

 
 
3. In the box next to “Site name” enter a name for your site. 
4. To browse for the folder that you want to hold all your web files, click on the 

folder icon on the right side of the box next to “Local Root Folder.” A dialog box 

Enter site name here, 
then…. 

click on the file folder icon to 
find the folder that will hold 
your web files 

You can ignore these 
two for now 
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like the following will appear: 
 

 
 

5. Click once on the directory you wish to use, then click the “Open” button. 
6. Now that you’ve set up a site, you’re ready to begin creating web pages. 

 
iv.  Tour of Dreamweaver opening screen 
 
Open Dreamweaver.  You should see a screen that looks something like this: 
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Click on “Create New HTML” and you will see a screen that looks similar to the one 
below: 
 

 
 
Property inspector: 
 
The Property inspector lets you view and change the attributes of an object.  The 
inspector is context-sensitive – it changes based upon what you have selected in the 
document window.  In the picture above, the Property inspector is showing basic 
formatting options for text, but if we were to insert a table, the Property inspector would 
reveal options for formatting that table.  Depending upon the selected object, there might 
be additional properties that are not automatically visible within the Property inspector.  
To see all of the properties, click the expander arrow located in the lower right corner of 
the inspector. 
 
With that preview of Dreamweaver out of the way, let’s get started! 
 
 

This is the 
document window. 
This is where your 
web page will 
appear. 

This is the “Insert” 
window. It contains 
shortcuts to some 
commonly executed 
commands. You can 
see other shortcuts by 
using the drop down 
menu. 

This is the Property Inspector. You will use it to modify the 
appearance of your screen. It may look different depending on 
what you are working on. 
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iv.  Set general page properties 
 
We’re going to give our first web page a title, and we’re going to change the background 
color and the text color.  We can do all of this by setting the page properties. 
 
From the Modify menu, select “Page Properties.” The following window will appear: 
 

 
 
 
 
If you click on any of the Categories on the left hand side, your options change on the 
popup screen. Select “Title/Encoding” and in the “Title” field , give your web page a 
descriptive title.  In our example of the Anthropology 185 course, the title used was:  
 
Rio Grande: Mario Montano Course 
 
Enter this title now, or some descriptive variation of it.  We’ll discuss more about the 
titles of web pages at the end of Section 1. 
 
Remember that we could have entered a descriptive page title on the toolbar of the 
document window as well.  In fact, you can modify a page title at any time using either 
the toolbar field or the “Page Properties” window. 
 
We can now specify a background color while we’re in the same “Page Properties” 
window.  Click the color box located next to the word Background.  Move the 
eyedropper over your favorite color swatch.  Dreamweaver offers you “web safe” colors 
in the presented color palette.  It is best to stick with one of these colors unless you 
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consult further with a color expert, because not all web browsers and monitors will 
present all color selections properly. 
 
To change the default text color, follow similar steps for the Text field. 
 
Notice that you can also alter the default colors for hyperlinks.  We don’t advise that you 
change these colors unless it really goes with the overall artistic nature of your web site.  
The classic royal-blue-and-underlined wording is a nearly universal symbol of a 
hyperlink, and altering it could confuse novice web users. 
 
Now that you have entered an appropriate title for your page, and now that you have 
changed the background and text colors, it is time to enter some basic text.  Please enter 
the following into the document window of Dreamweaver: 
 

The Rio Grande and San Luis Vally: History, Culture, and Conflict 
 
Notice that what you type appears in your selected font color.  Once you enter the text, 
you can center it, and you can make it a larger “heading.”  Experiment with the heading 
size that you like best (Heading 3 was actually used on the web page).  You can control 
aspects of the text by using the Property inspector. 
 
Now we’re ready to save our web page and preview it before moving on to the next 
section of the Dreamweaver tutorial. 
 
v.  Save your page and preview it in a web browser 
 
To save your work thus far, select “Save” under the File menu.  You’ll see the following 
window appear: 
 

 
 
 



Dreamweaver MX: Created by M. Gerein; Modified by P.Quinn ~ 20 

When saving your web page, be sure to do the following: 
1. Verify the location shown in the “Save in:” box shows the class folder you created 

on your H: drive. 
2. Provide a good file name for your web page.  By default in the screen snapshot 

shown above, Dreamweaver is proposing to use “Untitled-1” as the file name.  
Change this to “welcome.”  [More on file names versus page titles below.] 

3. Be sure to select “All Documents” (or “HTML Documents”) in the “Save as type” 
field below the file name.  This will automatically add the extension “.htm” to 
your file name. 

4. Click on the “Save” button. 
 
Previewing your web page 
 

1. Select “Preview in Browser” from the File menu 
2. Select the browser, Netscape or Internet Explorer, that you want to use.  It’s a 

good idea to preview your pages in both browsers and make note of any major 
differences in appearance between the two.  Consult your academic technology 
specialist if differences persist and you would like assistance in troubleshooting.  
 
Note: By default, Dreamweaver includes only Internet Explorer as a preview 
option.  To add Netscape to the list of browsers you can use to preview your page, 
ask your tech specialist for assistance 

 
PAGE TITLES VS. FILE NAMES 
 
Your web page needs BOTH a page title and a file name.  This section describes the 
importance of each one. 
 
Page titles 
 
The title of a web page describes the page.  It shows up in the title bar of the browser 
used to view it (go back and notice the screen snapshot of the AN185 page displayed in 
Internet Explorer on Page 2).  The page title is what appears in a browser’s History list.  
The page title is often used by search engines to catalogue your page.  Finally, when 
someone makes a bookmark (Netscape) or a favorite (Internet Explorer) of your page, the 
page title is what will appear as that bookmark or favorite.   
 
When giving your page a title, you should be as descriptive as necessary, so that visitors 
know what they might find if they visit it.  The use of spaces in your descriptive, unique 
page titles is fine (even recommended). 
 
Besides giving your web page a descriptive title, we recommend that you present some 
version of the title on web page itself (usually done as a Heading 1, 2, or 3).  That way, if 
visitors make their way to your web page, they know what they should be finding there. 
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File names 
 
The file name of a web page captures the technical name of the web page as it lives on 
your computer.  All web pages have file names with an extension of either .htm or.html 
(“fancier” pages might have different extensions, such as .asp or .cfm, but we won’t go 
into those extensions here).  This is similar to all Microsoft Word documents having an 
extension of .doc.   
 
Besides file names, you need to consider the directory structure of your files.  You will 
have one main web directory, and then you can have many subdirectories below it.  For 
example, you might have a course folder for AN185, but you could have another course 
folder for AN280.  When directories and subdirectories are used to organize your web 
materials, the directories will become part of your web address (or URL). 
 
Your home page (or main page) for your course web site should have the file name 
“welcome.htm.”  The file name “welcome.html” is also fine.  The “welcome” file name is 
special.  Pages with this file name come up automatically when the address of their main 
directory is typed into a browser.  This saves people some typing time when entering 
your web page address (or URL).   
 
An example might help: 
 
If I create a web page on my W: drive, in a folder called “AN185,” and I give it the file 
name “welcome.htm,” then the URL for this page is: 
 
http://faculty1.ColoradoCollege.edu/~ktjones/AN185 
 
But if I create the same web page in my “AN185” folder on my W: drive and I give it the 
name “riogrande.htm,” then the URL for this page is: 
 
http://faculty1.ColoradoCollege.edu/~ktjones/AN185/riogrande.htm 
 
Which URL would you rather type? 
 
It is very important how you name your web files.  Because these files are read by all 
sorts of computers (PCs, Macs, UNIX machines) we have to take the file names down to 
the least common denominator and make sure that there is nothing funny in them that 
some computer cannot understand.  Here are a couple of final tips about file names: 
 

·  Do not use spaces in your file names!  If you must use a long file name, use 
underscore characters (“such_as_this”) rather than spaces. 

·  Keep file names short.  Remember that the folder and file names you select will 
become part of the URLs that people must type to get to your pages.  Short file 
names reduce the likelihood of typos when people have to type the address. 

·  Use all lowercase letters.  Most web servers are not case-sensitive, but it’s best to 
be safe.  Lowercase letters are easier to type, anyway. 
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·  Use only letters and numbers – no “funny” characters (such as apostrophes, 
colons, semicolons, bullets, slashes, etc.). 

·  On the CC campus, our web servers also treat “default.htm” and “index.htm” as 
special file names, just like “welcome.htm.”  We recommend that you stick with 
“welcome.htm” when in doubt. 

·  You can use the special name “welcome.htm” for each unique subdirectory in 
your web folder.  For example, your main course page for PY101 can be named 
“welcome.htm,” as can your main course page for GS104.  Just try not to 
overwrite one directory’s welcome file with a version meant for a different folder! 

o Examples: http://faculty1.coloradocollege.edu/~kjones/PY101 
o http://faculty1.coloradocollege.edu/~kjones/GS104 
 

 
EDITING YOUR WEB PAGE 
Once you save your web page with a .htm extension, you can edit it within Dreamweaver 
later, of course.   
 
On a Mac, you can double-click a file created in Dreamweaver to have it open in 
Dreamweaver.  But on a PC, this may not happen.  The file may instead be opened by a 
web browser such as Internet Explorer or Netscape.  This is because files with a .htm 
extension are registered to Netscape or Internet Explorer, NOT to Dreamweaver.   
 
So, in order to edit your web page within Dreamweaver, first open Dreamweaver, and 
then open the web file from within Dreamweaver. 
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Dreamweaver MX 
Working with Tables 

 
 
Tables are one of the most useful design elements that you can use when designing web 
pages.  Tables allow you one of the few ways to control the design of your page.  Tables 
allow you to control width on the screen.  You should use tables to make your web pages 
scannable. 
 
Inserting Tables 
 
Do the following: 

Insert �  Table 
 
This will take you to the following screen 
 

 
 
Let’s take a moment to examine the settings. 
 
Rows: This allows you create a specific amount of rows 
 
Columns: This allows you to create a specific amount of columns 
 
Cell Padding:  This is the amount of space (in pixels) between the cell and the element 
inside the cell (i.e. text or graphics).  For browser compatibility this should be set to 0. 
 
Cell Spacing:  This is the amount of space (in pixels) the cells of your table.  For browser 
compatibility this should be set to 0. 
 
Width:  this allows you to control how big your table is.  Selecting the “In pixels” radio 
button and changing the number in the text area accomplishes this.  If you’re shooting for 
a 640 x 480 monitor you should change this number to something like 595.  If you’re 
going for 800 x 600 as your baseline you should change this number to 700. 
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Border:  This is the size of the borders in your table.  It’s in pixels.  If you don’t want a 
border, you should set this to 0.   
 

Table Properties 
 
If you highlight a table you can access even more table properties.  The properties 
window will change to the following: 
 

 
 
Note that you have the same amount of properties as when you inserted the table but now 
you have a few more options.  You can now change the background color, border or 
insert an image as a background for the table. 
 

Cell Properties 
 
You can also change different properties within an individual cell.  The most important 
item to identify here is that you can change the alignment properties for an individual 
cell.  To access the properties for a particular cell merely insert your cursor in the cell you 
wish to change. This will change the properties window to the following: 
 

 
 
The most important thing to know here are the alignment controls.   “Horiz” controls how 
an element fits within the cell of a table horizontally.  “Vert” controls how an element fits 
within the cell of a table vertically.  These are particularly important if you want an item 
to fit within a cell a certain way. 
 
“W” determines how wide your cell is in terms of pixels. 
“H” determines how high your cell is in terms of pixels. 
 
The first “Bg” will let you select a picture for a background in a cell. 
The second “Bg” will let you select a background color for your cell. 
The “Brdr” will let you pick a color for the border of that individual cell. 
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Dreamweaver MX 
Text, Graphics & Hyperlinks 

 
1. Creating a New Page 

 
There are many different ways to create a new page for your website: 

a. From the “File” menu at the top of your screen you could select “New”, 
and start with a completely blank page.  However, you would have to set, 
from scratch, all the page properties, etc. 

 
b. Another way to create a new page, especially if you want that page to have 

the same “look” as your first page, is to have your original page open, and 
then from the “File” menu at the top of your screen, select “Save As”. 

i. Save the page, with a new name, in your web folder, and it will 
retain the same properties, table layouts, etc, as your first page.  On 
the new page, simply remove the first page’s content, and enter the 
new content for your second page. 

 
 
 
 
 
“File” to 
“Save As” 
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2. Formatting Text 
 
If you have used word processing programs before to format text, you’ll find many of 
the same options are available to you in Dreamweaver.  The only difference is that 
your options are limited in Dreamweaver, due to restrictions in HTML, regarding the 
appearance of text on the web. 
 
To format text in Dreamweaver, first highlight the text that you wish to format.  Then 
make sure you have your “Properties” panel visible.  (Under the “Window” menu at 
the top of your screen, select “Properties”). 
 

 
Highlight the text you wish 
to format. 
 
Make sure your Properties 
panel is open. 
 
 
 
 

 
Format your text using options visible in the Properties panel for your highlighted 
text: 
 
·  Use the “Format” menu to select a preformatted Heading style. 

o Select a font from the menu of  “web-safe” fonts. 
�  Change the color of your font by clicking on the arrow of the palette icon. 

 

 
 

·  Select as size for your text 
·  Bold or italicize your text (never underline anything except a hyperlink!) 
·  Align your text left, center, right or justified. 

 
If you want to use text that isn’t “web-safe” on your page (for example, a title in a Celtic 
font), use a graphics program to create a “graphic” of your title, and insert the title like a 
picture. 
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Line Breaks vs. Hard Returns 
 
Formatting paragraphs or lines of text for a web page can be frustrating, in terms of line 
spacing.  The easiest way to manipulate line spacing is to remember the difference 
between using a Hard Return  (pressing the “Enter” key), and a Line Break (which is 
holding down the “Shift” key and then pressing the “Enter” key). 
 

A Hard Return automatically double-spaces the lines 
of your text (starts a new paragraph).  It will also 
allow you to have different formatting options for 
your line (here, we demonstrate left and right 
alignment). 
 
A line break takes you down to the next line, or 
single-spaces the lines of your text.  However, when 
using line breaks, the formatting amongst the lines is 
forced to share many properties. (Like the same 
alignment in this example). 
 
 
 
 

 
Cut & Paste Text Into Your Web Page 
 
If you have text from a file (like a Word Perfect document that contains your syllabus), 
open that text file.  Highlight the text you want for your web page.  Then select “Edit” 
from the menu at the top of your screen, and then select “Copy”. 
 
Switch back to your open web page in Dreamweaver.  Position the cursor where you 
want to place your text.  Then from the “Edit” menu at the top of your Dreamweaver 
window, select “Paste”.  The text should appear but it may require formatting. 
 

 
You will most likely find that the text you just 
pasted into your web page will need to be formatted 
differently. 
 
One tip for formatting pasted text: 

·  Highlight all the pasted text. 
·  From your Properties panel, select 

“None” from the “Format” pull-down 
menu. 

·  This will erase most of the “hidden” 
formatting that could cause frustrations 
while you try to get your text ready for 
the web. 
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3. Inserting & Formatting a Picture 
 

Position your cursor where you’d like to place the 
picture. 
 
From the menu at the top of the screen, select “Insert” 
and then “Image”. 
 
You will be guided to pick a picture file from your 
directory. 
 
NOTE: remember to put all images in your web folder! 
 
 
 
 

 
To change the properties of 
your picture, click on the 
picture to select it. 
 
All your formatting options 
will be available in the 
Properties panel. 
 
 
 
 
 
 

 
From the Properties Panel you can: 

·  Change the dimensions of the picture. 
·  Look at where the picture is located, and change that location 
·  You can add an “alt tag” that will appear when the mouse is hovering over your picture. 
 

 
·  You can add a border around your picture. 
·  Align the picture. 
·  And you can also open your picture in a program – outside of Dreamweaver – to edit the size, 

look, etc.  
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4. Hyperlinks 
 
There are four basic types of links you can use on your page, and one “cousin”. 

 
Email Links: 

·  From the “Insert” menu at the top of 
your screen, select “Email Link”. 

·  In the box that pops up, simply type the 
text you would like the email link to 
work with (i.e. “Email Peggy”) and the 
email address you’d like to link to. (i.e. 
peggy.quinn@coloradocollege.edu) 

 
 
 
URL Links (links to existing stuff on the 

web): 
  
To link to sites that already exists on the 
web: 

·  Highlight the text you wish to 
use as the link. 

·  In the Properties panel for that 
text, enter the URL in the 
“Links” field. 

·  Remember that you must 
include the http:// in your 
address. For example: 
http://www.coloradocollege.edu 

 
 
To link to another page in your web folder: 

·  To link, for example, your home page to a “Syllabus” page you have just 
created, highlight the text you wish to use as the link. 

·  In the Properties panel for that text, enter the file name for the “Syllabus” 
page (i.e. Syllabus.htm) in the “Links” field 

·  OR…..click on the yellow folder icon next to the “Links” field and navigate to 
the “Syllabus” file. 

 
Using an Image as a Link: 
You can set the properties for a picture to act as any one of the three types of hyperlinks 
already mentioned. 
 

·  Click on the picture to select it. 
·  Then, you can insert a hyperlink by following any of the instructions 

listed above. 
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The “Anchor” – A Cousin of the Hyperlink: 
 
An anchor is like a placeholder on a web page.  It is a component that could be called an 
“internal hyperlink”, since it only links areas on the same page. 
 
An anchor is best explained by an example. 
 
Let’s say that your web page contains a lengthy article.  Once the viewer has finished 
reading the article, you don’t want them to have to scroll all the way back to the top of 
the page.  You would rather that your reader could click a link that says “Return to Top” 
that would take them back to the top of your web page. 
 
To do this: 

 
Position your cursor where you would like to 
have the viewer “return” to once they have 
finished reading the article. 
 
From the “Insert” menu at the top of the 
screen, select “Invisible Tags” and then 
“Named Anchor” 
 
In the box that pops up, name your anchor 
something like “Top”, and press OK. 
 

 
 
An anchor icon will now appear where the anchor has been 
created. 
 
Note:  this icon is not visible when your page goes “live”. 
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At the end of your long article, type the 
words “Return to Top” and highlight 
them. 
 
In the Properties panel for that text, 
type #TOP in the Link field.   
 
 
 
 
 
 
 

 
The # sign indicates it’s an anchor link, and “Top” was the name we gave the anchor 
when we positioned it at the top of the page. 
 


